Спонсор проекта:
Лучший вариант для анонимности купить прокси на выделенном сервере IPANN.NET.
Ads



Последние комментарии
#1
Linups_Troolvalds пишет: » Хватит писать бред. МСВС (возможно) не работает на... (24.07.2017)
// Обзор и попытка установки МСВС 5.0
#2
watersoda пишет: » Да и RHEL под "Эльбрус" не помешал бы... (19.03.2017)
// Обзор и попытка установки МСВС 5.0
#3
watersoda пишет: » Небольшая поправка: ... через соответствующий паке... (19.03.2017)
// Обзор и попытка установки МСВС 5.0
#4
watersoda пишет: » Кстати, мелькала где-то информация, что Red Hat сд... (19.03.2017)
// Обзор и попытка установки МСВС 5.0
#5
watersoda пишет: »
Цитата:
... МСВС отстаёт от ДОСа по поддержке виде...
(16.03.2017)
// Обзор и попытка установки МСВС 5.0
#6
admin пишет: » watersoda, этот ноутбук выпущен в 2012 году wink
Убунт... (16.03.2017)
// Обзор и попытка установки МСВС 5.0
#7
watersoda пишет: » И вот ещё, правда речь про МСВС 3.0:
Цитата:
Устрои...
(08.03.2017)
// Обзор и попытка установки МСВС 5.0
#8
watersoda пишет: » Я где-то читал, что ВНИИНС предоставляет список об... (08.03.2017)
// Обзор и попытка установки МСВС 5.0
#9
дохтур пишет: »
Gentoo написал:
Вот мне лично нахуй не надо ни одн...
(02.02.2017)
// Письма неадекватов
#10
дохтур пишет: »
Gentoo написал:
Вот мне лично нахуй не надо ни одн...
(02.02.2017)
// Письма неадекватов
#11
Gentoo пишет: » >>Autocad, Kompas, CorelDraw, SolidWorks, AD... (30.01.2017)
// Письма неадекватов
#12
watersoda пишет: » Just for fun как он есть.biggrin (15.01.2017)
// Линукса нет! Нас обманули !!!
#13
дохтур пишет: » admin, ага, ещё вот проприетарная лицензия на обще... (13.01.2017)
// Письма неадекватов
#14
admin пишет: » дохтур, а ранили его "тупые виндузяги" с... (13.01.2017)
// Письма неадекватов
#15
дохтур пишет: » Это была какая-то очень ранимая заблудшая душа (13.01.2017)
// Письма неадекватов
Quotes
Никогда не входите в систему под пользователем Sroot, используйте для этой цели команду Ssu

Драйверы принтера | автор: admin | 6 августа 2015 |

Категория: GNU/Linux


Каждый нормальный линуксоид, перед покупкой девайса интересуется, совместим ли этот девайс с гнулинуксом и есть ли свободные драйвера .

Погуглив на тему "Canon PIXMA IP1000 Linux" я сразу нашёл статью "Установка принтера Canon Pixma IP1000", где чётко и подробно расписано как установить фирменный (хоть и GPL) драйвер от Canon.

В конце статьи автор перезагружает сервер печати варварским методом:

sudo killall cupsd
sudo cupsd

Чем ему не нравится: /etc/init.d/cupsd restart ? Или может убунтовцы свои компы предпочитают кувалдой перезагружать ?

В общем, статья правильная, принтер работает. Но оказывается что этот драйвер не поддерживает печать оттенками серого. Да и на официальном сайте драйвера ничего об этом не сказано
А покупать цветную краску для чёрно-белой печати ... сами понимаете smile
Что самое интересное, это драйвер несмотря на десятилетний возраст своих бинарников, работает даже на современном гнулинуксе (нужно всего лишь подправить ссылки на библиотеки). В других свободных программах столько зависимостей что проще винду установить и не парится. За 5 лет пользования Гнулинуксом, я заметил что у проприетарных гнулинуксовых программ, зависимостей намного меньше чем у их свободных аналогов. Хотя, те же свободные программы в виндовсе устанавливаются за три клика и совершенно без проблем.

Пробую другой драйвер.
Сразу оговорюсь, что это драйвер для Убунты, но у меня Дебиан. В Убунте куча глюков, ну её к чёрту.
Один разработчик решил допилить старые кэноновские драйверы, но установить их не получилось. Как я ни старался, принтер тупо мигал индикатором и ничего не печатал.

Перепробовав все свободные драйверы, я решил установить платный проприетарный TurboPrint. Но тут тоже не обошлось без пляски с бубном:
dpkg -i turboprint.deb
(Чтение базы данных ... на данный момент установлено 127316 файлов и каталогов.)
Подготовка к замене пакета turboprint 1.96-4 (используется файл turboprint_1.96-4_i386.deb) ...
Распаковывается замена для пакета turboprint ...
dpkg: зависимости пакетов не позволяют настроить пакет turboprint:
turboprint зависит от libglib1.2 | libglib1.2ldbl, однако:
Пакет libglib1.2 не установлен.
Пакет libglib1.2ldbl не установлен.
turboprint зависит от libgtk1.2, однако:
Пакет libgtk1.2 не установлен.
turboprint зависит от cupsys, однако:
Пакет cupsys не установлен.
dpkg: не удалось обработать параметр turboprint (--install):
проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для man-db ...
При обработке следующих пакетов произошли ошибки:
turboprint

Пришлось удалять зависимость cupsys из пакета turboprint:
1. dpkg-deb -x turboprint_2.15-2_i386.deb tmpdir
2. dpkg-deb --control turboprint_2.15-2_i386.deb tmpdir/DEBIAN
3. nano tmpdir/DEBIAN/control
4. dpkg -b tmpdir turboprint_2.15-2_i386.deb

Вот таким образом удалось запустить в гнулинуксе старенький принтер Canon pixma ip1000.

Уважаемый пользователь, вам необходимо зарегистрироваться, чтобы посмотреть скрытый текст!


Комментарии посетителей

#1. Rector

Rector
И чё?

#2. Armanx64

Armanx64
Ну здравствуйте. Я снова здесь.

#3. Armanx64

Armanx64
Кейген на драйвера.
Уж и не думал, что увижу такое.

#4. wr224

Armanx64, это линукс 70е годы. Велкам

#5. Linfan

Linfan
Цитата:
libgtk1.2


афтырь некромант и содомит, не иначе biggrin

#6. wr224

Linfan написал:

афтырь некромант и содомит, не иначе biggrin

Тобой любимая поделка других средств не предоставляет

#7. admin

Linfan написал:
афтырь некромант и содомит, не иначе

Автор статьи или автор программы ? Turboprint - это единственный на сегодняшний день софт, позволяющий практически без проблем запустить в гнулинуксе известные принтеры от Canon, HP, Epson и Brother. Примечательно что Canon пишет драйвера, но только под SuSe и RedHAT/Fedora. А Turboprint продаёт свои портативные сборки этих же драйверов по цене 30 евро за копию.

Что касается gtk1.2, далеко не каждый гнулинуксовый софт времён gtk1.2 может адекватно работать в современном дистрибутиве. В случае с турбопринтом, достаточно поменять зависимости в пакете или поставить ссылки gtk1.2 - gtk3.0

30 евро за драйвер!

#8. wr224

admin написал:
30 евро за драйвер!

Не заплатишь за систему - заплатишь в другом месте. До "жадных детей" никак не дойдет эта простая аксиома

#9. Oxygent

admin, Через что здесь сделан мост между сайтом и форумом? У тебя никуя не работает в данный момент. Я уж решил плюнуть и зарегистрировать просто свежую учётку, но х#й там, регистрация на сайте не добавляет учётку на форум. Если slor это ты и всё до сих пор настроено именно так... Ну... Ёбаный стыд тогда.
http://ngcms.ru/forum/viewtopic.php?pid=40475
Последние два пункта должны стоять "Да".
А самая последняя рабочая версия лежит тут: http://ngcms.ru/forum/viewtopic.php?id=1688
дохтур
Rector написал:
И чё?
Линукс в который раз победил прогресс

#11. AleksK

Turboprint последний выпуск в 2011 году... ну-ну судя по всему он просто необходим всем пользователям Linux, MacOS и даже Windows...
Лучше посоветуйте правильный принтер, для работы с линухсом.

#13. Apollo 11

Линукс де Мазох написал:
Лучше посоветуйте правильный принтер, для работы с линухсом


Для тебя такого не существует. Смирись…
Svart Testare
Надо же, никогда не думал, что снова здесь буду писать :)

#15. admin

Oxygent, думаешь ты один такой умный ? Я эти параметры проверил в первую очередь.

#16. Linfan

Linfan
Svart Testare, итить! Ты ба, ще не вмер ;)

#17. Linfan

Linfan
wr224, я тя умоляю, не зачухивай. Много ты знаешь про поделки :) нормальные принтеры, с поддержкой PostScript работают на ура. А всякое-разное, заточенное под вынь, нэхай из-под нее и работает. Делов то...
Antimateriale
admin, Да хр№н тебя знает. Мёртвый проект ты почему-то поддерживать решился. Обычно очень трудно накосячить в том, что просто работает сразу и без усилий.

#19. Rector

Rector
Antimateriale, Может хватит наезжать на админа? Свои проекты вспомни. Да и вообще, пишешь ты не в ту тему.
Antimateriale
Rector, какая была сверху, в какой началось, в такую и пишу. Мои проекты? Моих проектов никогда не было, были только потуги саобчиства, в которых я выступил безвозмездным сайтостроителем. А что с технической точки зрения было не так? Все интеграции работали, даже кириллица в никах была.
Были ограничения, опять же, самого движка. По части комментариев и bb-кодов в них же, преимущественно.
Ну и так, халявный хостинг накладывал определенные ограничения в производительности.
А на большее всё-равно саобчиства этого и не хватило.

#21. Rector

Rector
Antimateriale, да я ничего плохого за твои проекты не говорю. Просто - завязывай наезжать на человека. Если есть чем помочь, так помоги ему, без особого сарказма -) А вообще, хорошо что мы тут вроде как и собрались - ветераны -))
Director-cemetery
Смотрите, говорит, пока я хлопал пять раз в ладоши, где то в Африке умер СЛОР.
Из зала - "Ты, это мужик... Завязывай ладошками хлопать...
дохтур
Director-cemetery написал:
Смотрите, говорит, пока я хлопал пять раз в ладоши, где то в Африке умер СЛОР
Так субдомен .org.ru ещё никто не называл =)

#24. Linfan

Linfan
дохтур, да ладно, Серж Брин кого Северной Нигерией называл? ;)
Svart Testare
Linfan,

Я живее всех твоих юниконвертеров буду!

#26. petrun

Да, чуваки, уже не думал что вас встречу снова.

#27. Linfan

Linfan
Svart Testare, чо, в репы дебиана тебя прописали? Растешь )))
Просмотров: 15214